-
Notifications
You must be signed in to change notification settings - Fork 0
/
Copy pathLevelOrderBinaryTree.java
142 lines (107 loc) · 2.66 KB
/
LevelOrderBinaryTree.java
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
130
131
132
133
134
135
136
137
138
139
140
141
142
/*
Given a pointer to the root of a binary tree, you need to print the level order traversal of this tree. In level-order traversal, nodes are visited level by level from left to right. Complete the function and print the values in a single line separated by a space.
For example:
1
\
2
\
5
/ \
3 6
\
4
For the above tree, the level order traversal is .
Input Format
You are given a function,
void levelOrder(Node * root) {
}
Constraints
Nodes in the tree
Output Format
Print the values in a single line separated by a space.
Sample Input
1
\
2
\
5
/ \
3 6
\
4
Sample Output
1 2 5 3 6 4
Explanation
We need to print the nodes level by level. We process each level from left to right.
Level Order Traversal:
*/
import java.util.*;
import java.io.*;
class Node {
Node left;
Node right;
int data;
Node(int data) {
this.data = data;
left = null;
right = null;
}
}
class Solution {
/*
class Node
int data;
Node left;
Node right;
*/
//BFS Tarversal
//3 Methods: 1)printTree 2)Height 3)printLevel
public static void levelOrder(Node root) {
int h=height(root);
int i;
for(i=1;i<=h;i++){
printCurrentLevel(root,i);
}
}
public static int height(Node root){
int res=0;
if(root==null)return res;
int l=height(root.left);
int r=height(root.right);
return (int)(Math.max(l,r)+1);
}
public static void printCurrentLevel(Node root,int level) {
if(root==null)return;
else if(level==1)System.out.print(root.data+" ");
else{
printCurrentLevel(root.left,level-1);
printCurrentLevel(root.right,level-1);
}
}
public static Node insert(Node root, int data) {
if(root == null) {
return new Node(data);
} else {
Node cur;
if(data <= root.data) {
cur = insert(root.left, data);
root.left = cur;
} else {
cur = insert(root.right, data);
root.right = cur;
}
return root;
}
}
public static void main(String[] args) {
Scanner scan = new Scanner(System.in);
int t = scan.nextInt();
Node root = null;
while(t-- > 0) {
int data = scan.nextInt();
root = insert(root, data);
}
scan.close();
levelOrder(root);
}
}